Charts missing after reinstalling 2020.29

TeeChart FireMonkey (Windows,OSX,iOS & Android) for Embarcadero RAD Studio, Delphi and C++ Builder (XE5+)
Post Reply
Newbie
Newbie
Posts: 19
Joined: Thu Aug 29, 2019 12:00 am

Charts missing after reinstalling 2020.29

Post by » Thu Apr 16, 2020 11:42 pm

I installed 10.3.3 so I had to reinstall both Fast Reports and TeeCharts. After installing and opening up my program, all my charts and series are missing from my forms. I restored my FMX files from last week and they are still not there. Verified my library paths are correct.

What could have caused this and how do I fix it? I have uninstalled and reinstall to no avail.

Yeray
Site Admin
Site Admin
Posts: 8980
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: Charts missing after reinstalling 2020.29

Post by Yeray » Fri Apr 17, 2020 6:25 am

Hello,

Are you getting any error message?
Can you drag a new TChart component into a new form in a new project?
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

Newbie
Newbie
Posts: 19
Joined: Thu Aug 29, 2019 12:00 am

Re: Charts missing after reinstalling 2020.29

Post by » Fri Apr 17, 2020 7:31 am

I can drag a regular chart, but when I dray a Chart3d, it only shows in the Structure, not the form. I can double click it and create series, but again, it doesn't show on the form on a new project.

Newbie
Newbie
Posts: 19
Joined: Thu Aug 29, 2019 12:00 am

Re: Charts missing after reinstalling 2020.29

Post by » Fri Apr 17, 2020 7:32 am

I get no error message starting Delphi or opening my project. Only when I try to compile it, Delphi wants to remove it. On the new project, it will compile but the chart is not visible on the form.

Newbie
Newbie
Posts: 19
Joined: Thu Aug 29, 2019 12:00 am

Re: Charts missing after reinstalling 2020.29

Post by » Fri Apr 17, 2020 7:39 am

Sorry for the multiple posts. I wanted to let you know, Fast Reports Preview disappeared also. I am working with them too. So, it might be a Fast Report problem. I was able to put a preview on a new project, though it is not displaying properly. See the attachment.
Attachments
2020-04-17_0037.png
2020-04-17_0037.png (31.25 KiB) Viewed 8842 times

Newbie
Newbie
Posts: 19
Joined: Thu Aug 29, 2019 12:00 am

Re: Charts missing after reinstalling 2020.29

Post by » Fri Apr 17, 2020 12:00 pm

I think I will just uninstall everything and go back to Delphi 10.3.2. Everything was fine there. Hopefully, I didn't break my program.

Newbie
Newbie
Posts: 19
Joined: Thu Aug 29, 2019 12:00 am

Re: Charts missing after reinstalling 2020.29

Post by » Fri Apr 17, 2020 1:37 pm

I decided to install just 10.3.3 and TeeChart and not to install Fast Reports. When I started up my app in 10.3.3, I ignored all the errors of the missing Fast Reports. The DBCharts, I have two, didn't display in my program. Not sure what the problem is with 10.3.3 and TeeCharts, but it is just not working. I even tried to install older versions of TeeChart with the same results.

I can create a new project though and drop in a DBChart and it does display. Just not in the current app I have coded in 10.3.2. So for now, I have to uninstall everything and go back to 10.3.2 and hopefully my program is not broke.

Newbie
Newbie
Posts: 19
Joined: Thu Aug 29, 2019 12:00 am

Re: Charts missing after reinstalling 2020.29

Post by » Fri Apr 17, 2020 3:37 pm

At first, it was even working in 10.3.2 even though I restored last weeks fmx's and the pas from history. So I restored from Carbonite AND MY CHARTS ARE BACK TO NORMAL. It is kinda weird. Any idea why the history files would work but the Carbonite files did?

Now I will try to uninstall everything again and then try 10.3.3 again and let you know.

Newbie
Newbie
Posts: 19
Joined: Thu Aug 29, 2019 12:00 am

Re: Charts missing after reinstalling 2020.29

Post by » Fri Apr 17, 2020 5:18 pm

Got everything working now in 10.3.3. Thank you for your help.

Yeray
Site Admin
Site Admin
Posts: 8980
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: Charts missing after reinstalling 2020.29

Post by Yeray » Thu Apr 23, 2020 8:08 am

Hello,

Sorry for the delay here.
It may be a case of wrong paths (rubbish produced by multiple installs and uninstalls). I'd have suggested you check the HowTo setup Paths in the IDE post.

Anyway I'm glad to hear it's working for you.
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

Post Reply