Page 1 of 1

Can't Create & Build a project

Posted: Thu Mar 22, 2007 8:13 pm
by 8739618
When I click on Create & Build from the Build menu on my project, I get a progress bar (Creating topic files) that goes to 100 and then an empty dialog with a disabled cancel button and the title "Please wait..." and ceases to do anything. It's not using any processor time and I don't see any additional processes it spawned that it might be waiting on. It doesn't appear to have actually compiled any help files either. The only way to close the app at this point is to kill the process.

I followed the link on the website to download the vs2k5 sdk and get the help sdk, and TeeGofer is pointing at them in the Version Information dialog. That dialog has no items marked in red.

The SDK path says:
HTML Help v2.x SDK is installed
d:\Program Files\Visual Studio 2005 SDK\2006.09\VisualStudioIntegration\Archive\HelpIntegration\hxcsrv.exe, Version: 2.05.50727.42 (RTM.050727-4200)

What am I doing wrong?

Posted: Fri Mar 23, 2007 8:30 am
by narcis
Hi agleader,

We’ve been aware of the problem for a while and have been unable to find a solution to it. Building the outputted files using the v1 workshop works fine.

TeeGofer builds the HTML v1 projects without a problem and leaves them in the ProjectOutputFolder of Options -> Project Options. The HTML v1 project file, the *.hhp file, can be opened using the Microsoft HTML workshop tool and can be built without a problem. The issue is that the command line calling of hhw.exe within the TeeGofer ide seems to be failing for a reason which is beyond the reach of the VS2005 debugger; we will continue investigating the issue and will post a new build if or when we find a fix.

Posted: Fri Mar 23, 2007 2:29 pm
by 8739618
Do you have an idea how long it will take to resolve the issue?

I tested the v1 compiling with help workshop and that works, but I really wanted to build v2 help files. What do I need to do to build those manually?

Posted: Thu Mar 29, 2007 4:02 pm
by Marc
Hello,

There seems to be a problem with the way the ProgressWindow is functioning. The underlying compilation functionality checks out ok but the status flow to the progress window is incorrect. We're working on resolving this and will post an update and corrected version shortly.

Regards,
Marc Meumann

Posted: Thu Mar 29, 2007 5:35 pm
by Marc
Hello,

We have put a new Test version of TeeGofer.exe on the web page. We still have some checks left to do but the basis of the issue has been resolved and you should find the version usable. Please let us know if there's any feedback of interest.

We'll follow with a maintenance release update when checks are complete.

With thanks.
Regards,
Marc

Posted: Thu Mar 29, 2007 7:31 pm
by 8739618
I got the test version and it works just fine. I did manage to make it crash once when I went to save after I made a change to the namespace filters and tried to save the project while VS2k5 help was open, but I cannot reproduce it.

I'll continue to use this version and let you know of any reproducable bugs I come across.

Thanks!

Same problem

Posted: Mon May 05, 2008 2:17 pm
by 8743977
I am having the same problem as described in this original thread. I thought it was with the eval version (which was fairly old) so I bought and downloaded the latest version, but it still happening.

Posted: Mon May 05, 2008 2:29 pm
by narcis
Hi rmarcell,

Have you downloaded the text version called TeeGoferMarch2007.zip from 29th March 2007? It is a available at the bottom of TeeGofer v2 download page.