Page 1 of 1

Strange visual behaviour with Windows in Japanese

Posted: Tue Mar 06, 2018 7:59 am
by 9343260
Hello,

One customer using Windows 10 in Japanese reported a problem with the TeeTree which we have never faced before:

The TeeTree should look like this:
Image

But for this customer it looks like this:
Image

The texts are not visible and the icons are like shrinked on each other.

Have you ever faced such a situation or have any idea about what could produce such a problem ?

We are using TeeTree v2.0.

Thank you if you have any feedback.

Re: Strange visual behaviour with Windows in Japanese

Posted: Tue Mar 13, 2018 10:18 am
by yeray
Hello,

I'm trying to reproduce the problem with this simple example:

Code: Select all

procedure TForm1.FormCreate(Sender: TObject);
var i, j: Integer;
begin
  for i:=1 to 2 do
    with Tree1.AddRoot('ルート ' + IntToStr(i)) do
    begin
      Expanded:=True;
      Border.Hide;
      for j:=1 to 4 do
      begin
        with AddChild('子供 ' + IntToStr(j)) do
        begin
          ImageIndex:=tiChecked;
          Border.Hide;
          with AddChild('サブチャイルド 0') do
          begin
            ImageIndex:=tiChecked;
            Border.Hide;
          end;
        end;
      end;
    end;
end;
But it seems to work fine for me here:
Project3_2018-03-13_11-16-29.png
Project3_2018-03-13_11-16-29.png (3.64 KiB) Viewed 1759 times
Could you please modify the code above or arrange a simple example project we can run as-is to reproduce the problem here?

Thanks in advance.

Re: Strange visual behaviour with Windows in Japanese

Posted: Tue Mar 20, 2018 7:32 am
by 9343260
Hello Yeray,

Thank you for your answer.
We think we have found the problem: our user told us the TeeTree was working, he installed MS Office 2013 and the Tree was not working anymore. After some researches it appears that some Microsoft users have experienced problems with treeview components in MS Office 2013.

We have suggested our user to uninstall Office 2013 to check if it was the cause of the problem, but we didn't have any feedback since.

For the moment we can consider that the problem is not linked with TeeTree component but with MS Office 2013.

Re: Strange visual behaviour with Windows in Japanese

Posted: Tue Mar 20, 2018 8:44 am
by yeray
Hello,

Thanks for the feedback.
Don't hesitate to let us know if you (or the user) still have problems with it.