Display settings and font size

TeeChart VCL for Borland/CodeGear/Embarcadero RAD Studio, Delphi and C++ Builder.
EdDressel
Newbie
Newbie
Posts: 31
Joined: Mon Nov 25, 2019 12:00 am

Display settings and font size

Post by EdDressel » Thu Jul 30, 2020 4:06 pm

Delphi 10.4; TeeChart Pro v 2020.30.200525 32 bit

I have a simple demo (attached) that shows a problem that we are having in our application: when someone increases the Display setting font size from 100% to 200%, the font size in the charts increase 300%.

Here are two screenshots of what it looks like with the 100% font on the left and the 300% font on the right. I measured the height of the bracket on the label at the top and it goes from 12 pixes high at 100% to 21 pixels high at 200%, while the mark text in the chart goes from 9 pixels height to 32 pixels heigh.

Image

Is there something we are doing incorrectly?

Thank you,

Ed Dressel
Attachments
Display Size.zip
(187.59 KiB) Downloaded 76 times
Ed Dressel
President
RetireReady Solutions

wasowerby
Newbie
Newbie
Posts: 19
Joined: Thu May 14, 2020 12:00 am

Re: Display settings and font size

Post by wasowerby » Sat Aug 01, 2020 5:44 pm

I wonder if this issue is related to the 'TChartPageNavigator and High DP' problem discussed earlier. In the chart I showed, the titles and axes overlap when the chart is displayed in a 175% scaled up display. This seems to be caused by the very large scaled up chart font sizes - much larger that all other scaled up fonts on other grids etc in the application. There seem to be certain similarities here between the two issues.

Christopher
Guru
Posts: 1270
Joined: Fri Nov 15, 2002 12:00 am

Re: Display settings and font size

Post by Christopher » Mon Aug 03, 2020 9:49 am

Hello Ed,

Delphi 10.2 Update 3 on Windows 10 v.1903 using TeeChart Pro v2020.30.200525 32bit VCL

I'm not sure if I'm doing this right - I compile your project in release mode, then I change the display font size like this:
ApplicationFrameHost_2020-08-03_11-45-17.png
ApplicationFrameHost_2020-08-03_11-45-17.png (153.74 KiB) Viewed 2284 times
Then I run the exe and get this:
explorer_2020-08-03_11-41-17.png
explorer_2020-08-03_11-41-17.png (96.14 KiB) Viewed 2284 times
Could you please confirm or otherwise correct me on whether I'm doing this right?
Best Regards,
Christopher Ireland / Development & Support
Steema Software
Avinguda Montilivi 33, 17003 Girona, Catalonia
Tel: 34 972 218 797
http://www.steema.com
Instructions - How to post in this forum

EdDressel
Newbie
Newbie
Posts: 31
Joined: Mon Nov 25, 2019 12:00 am

Re: Display settings and font size

Post by EdDressel » Mon Aug 03, 2020 2:07 pm

That is similar to what I am doing, but I am using Delphi 10.4. Did you try that?
Ed Dressel
President
RetireReady Solutions

Christopher
Guru
Posts: 1270
Joined: Fri Nov 15, 2002 12:00 am

Re: Display settings and font size

Post by Christopher » Mon Aug 03, 2020 3:38 pm

EdDressel wrote:
Mon Aug 03, 2020 2:07 pm
That is similar to what I am doing, but I am using Delphi 10.4. Did you try that?
No, I'm afraid I didn't - I don't usually work on the Delphi side of things and only have access to Delphi 10.2 Update 3 at the moment. I think I might be able to get hold of a more up-to-date version of Delphi next week.
Best Regards,
Christopher Ireland / Development & Support
Steema Software
Avinguda Montilivi 33, 17003 Girona, Catalonia
Tel: 34 972 218 797
http://www.steema.com
Instructions - How to post in this forum

Christopher
Guru
Posts: 1270
Joined: Fri Nov 15, 2002 12:00 am

Re: Display settings and font size

Post by Christopher » Tue Aug 04, 2020 9:47 am

Hello Ed,

One thing I thought we could try in the meantime is exchange *.exes - I send you the Release build I create here to see if it behaves the same at your end, and you send me yours. In this way we should be able to determine if it's the build version of Delphi that's at issue or not.

Here's mine:
http://www.steema.com/files/public/support/Win32.zip
Best Regards,
Christopher Ireland / Development & Support
Steema Software
Avinguda Montilivi 33, 17003 Girona, Catalonia
Tel: 34 972 218 797
http://www.steema.com
Instructions - How to post in this forum

EdDressel
Newbie
Newbie
Posts: 31
Joined: Mon Nov 25, 2019 12:00 am

Re: Display settings and font size

Post by EdDressel » Tue Aug 04, 2020 7:29 pm

Good thinking.

I am off site but have my laptop with a high-density display--I ran both programs: my compiled program reproduces the problem, your compiled program does not have the problem.

Ed Dressel
Ed Dressel
President
RetireReady Solutions

Christopher
Guru
Posts: 1270
Joined: Fri Nov 15, 2002 12:00 am

Re: Display settings and font size

Post by Christopher » Wed Aug 05, 2020 2:19 pm

Hello Ed,

right, in which case I've added this issue to our issue tracker with id=2364, which means we will look at a fix to it before the next release.
Best Regards,
Christopher Ireland / Development & Support
Steema Software
Avinguda Montilivi 33, 17003 Girona, Catalonia
Tel: 34 972 218 797
http://www.steema.com
Instructions - How to post in this forum

EdDressel
Newbie
Newbie
Posts: 31
Joined: Mon Nov 25, 2019 12:00 am

Re: Display settings and font size

Post by EdDressel » Wed Aug 05, 2020 10:24 pm

Thank you. FYI--for my company, this is a very pressing issue as it has compromised my software on a lot of systems.
Ed Dressel
President
RetireReady Solutions

wasowerby
Newbie
Newbie
Posts: 19
Joined: Thu May 14, 2020 12:00 am

Re: Display settings and font size

Post by wasowerby » Thu Aug 06, 2020 10:57 am

Please don't forget my issue 'TChartPageNavigator and High DP' problem discussed earlier. This issue looks very similar to mine. Irrespective of the font size issue, the navigator buttons are not scaled up at 175% - as shown in my issue. It just looks as though TChart doesn't scale up properly at the moment.

Andrew

Christopher
Guru
Posts: 1270
Joined: Fri Nov 15, 2002 12:00 am

Re: Display settings and font size

Post by Christopher » Fri Aug 07, 2020 3:44 pm

Ed,

just to let you know that Andrew ran the demo you posted at the beginning of this thread using Delphi 10.4 with all the updates, and it seems that it worked okay for him with increased DPI, as he mentions here.
Best Regards,
Christopher Ireland / Development & Support
Steema Software
Avinguda Montilivi 33, 17003 Girona, Catalonia
Tel: 34 972 218 797
http://www.steema.com
Instructions - How to post in this forum

wasowerby
Newbie
Newbie
Posts: 19
Joined: Thu May 14, 2020 12:00 am

Re: Display settings and font size

Post by wasowerby » Sat Aug 08, 2020 8:55 am

Well, I tested at W10 Pro (with latest updates) Display Settings>Scale and Layout>175%. It looks as though Ed's customers may be using a different method to increase Font size only? I can't actually find the method he shows in his message. So I'm not sure my results are relevant to him or not.

Andrew

wasowerby
Newbie
Newbie
Posts: 19
Joined: Thu May 14, 2020 12:00 am

Re: Display settings and font size

Post by wasowerby » Sat Aug 08, 2020 5:01 pm

Well, as described in my 'TChartPageNavigator and High DPI' post, my problem was having the wrong settings in the Chart>Axis properties. Ok for 100% scaling but not for 175% or greater. Clearly different to this issue. Apologies for the 'red herring'.

Andrew

EdDressel
Newbie
Newbie
Posts: 31
Joined: Mon Nov 25, 2019 12:00 am

Re: Display settings and font size

Post by EdDressel » Thu Aug 13, 2020 2:39 pm

Chris:

I can reproduce the problem and can even see in Andrew's image (see the font sizes on the tab and the chart are different, and I should not him posting in this thread for you to focus on his thread is a bit frustrating).

This is a major problem with my app is real and makes the charts unusable. Here is an image from my app at 200%:

Image

That is compiled with 10.3.

I spent the time and included a demo--did you even try it?

Ed Dressel
Ed Dressel
President
RetireReady Solutions

Christopher
Guru
Posts: 1270
Joined: Fri Nov 15, 2002 12:00 am

Re: Display settings and font size

Post by Christopher » Thu Aug 13, 2020 2:59 pm

Hello Ed,

unless I'm mistaken, which of course I could be, I tried the app you posted and specified my results in this post of mine - in this post of yours you said that the exe I compiled on my machine using 10.2.3 worked okay for you, which prompted me to add an issue to our tracker with id=2364.

Do you see this as a fair summary of the situation so far?
Best Regards,
Christopher Ireland / Development & Support
Steema Software
Avinguda Montilivi 33, 17003 Girona, Catalonia
Tel: 34 972 218 797
http://www.steema.com
Instructions - How to post in this forum

Post Reply