Delphi 10.4 Install Error

TeeChart VCL for Borland/CodeGear/Embarcadero RAD Studio, Delphi and C++ Builder.
Post Reply
Newbie
Newbie
Posts: 1
Joined: Tue Dec 17, 2019 12:00 am

Delphi 10.4 Install Error

Post by » Mon Jun 08, 2020 9:32 am

Good morning.
I have installed version 2020.30 of the teechart pro over the 2 versions of delphi that I have.
Version 10.2 worked without any problem in version 10.4, it gives me this error when opening.
Attachments
Captura.JPG
Captura.JPG (29.74 KiB) Viewed 1426 times

Yeray
Site Admin
Site Admin
Posts: 8910
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: Delphi 10.4 Install Error

Post by Yeray » Mon Jun 08, 2020 10:14 am

Hello,

The error message "Cannot load package *Tee*. It contains unit *, which is also contained in package *Tee*", where any of the *Tee* packages ends with a "0" (*Tee*0), indicates that the TeeChart Standard package that was shipped with the IDE (*Tee*0) is still trying to be loaded, and this creates a conflict with the version you've just installed.

There are two possible causes and solutions for this error:

- If the TeeChart Standard/Lite package shipped with the IDE (*Tee*0) is present and selected in the list of packages in the IDE, please uncheck it. Then you should be able to select the TeeChart Pro/Std commercial package (*Tee*) in the same list.

- There are some 3rd party tools (*) that can be referencing the TeeChart Standard/Lite package shipped with the IDE, and thus causing this conflict. Please try to uncheck temporally any 3rd party tool package you may have installed in the list of packages to try to identify which one is causing the conflict.

(*) Some known 3rd party tools using TeeChart Standard/Lite are: FastReports, DevExpress and ReportBuilder.
Steema Software supports the integration of TeeChart into QuickReport and IntraWeb. Any other integration is supported by the 3rd party tool manufacturer.
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

WilliE
Newbie
Newbie
Posts: 6
Joined: Tue Apr 03, 2018 12:00 am

Re: Delphi 10.4 Install Error

Post by WilliE » Mon Jun 08, 2020 7:17 pm

Hello Yeray
.with Delphi 10.4 and TeeChart Pro VCL FMX Source Code 2020.30 now it is all fine.

But I have jet massive problems with TeeChart Pro VCL FMX Source Code 2020.30 and Delphi 10.3.3.

In both installs, I have the same third party components (each in different paths for Delphi 10.3.3 and Delhi 10.4)

So i tried to deinstall TeeChart 2020.30 (with teerecomplie) and install TeeChart 20220.28 for Delphi 10.3.3 (before I installed Delphi 10.4 all was ok with TeeChart 2020.28 and Delphi 10.3.3). However, I get the "same" error now with TeeChart 2020.28 with Delphi 10.3.3

Willi

Yeray
Site Admin
Site Admin
Posts: 8910
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: Delphi 10.4 Install Error

Post by Yeray » Tue Jun 09, 2020 4:50 am

Hello Willi,

Installing & uninstalling & reinstalling several times probably leaves some undesired entries in the paths on your IDE. It's always a good idea to clean the paths following the instructions here.
However, if you are getting an error about a conflict with a Tee package ending with zero (*Tee*0), then follow the instructions on the post above since you seem to have packages loading different versions of TeeChart and you need to unify all them.
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

Post Reply