TeeChart.2017.22 is not compatible with the RAD 10.2.2

TeeChart VCL for Borland/CodeGear/Embarcadero RAD Studio, Delphi and C++ Builder.
anauta2017
Newbie
Newbie
Posts: 3
Joined: Mon Apr 03, 2017 12:00 am
Contact:

TeeChart.2017.22 is not compatible with the RAD 10.2.2

Post by anauta2017 » Wed Dec 13, 2017 10:37 am

After upgrade to RAD 10.2.2 TeeChartVCLFMX-2017.22 binaries refused to work, I had to recompile library from source code.
Moreover, recompiled TeeChart3D can not be used with delphi, but works for C++Builder.

Yeray
Site Admin
Site Admin
Posts: 8730
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: TeeChart.2017.22 is not compatible with the RAD 10.2.2

Post by Yeray » Wed Dec 13, 2017 1:09 pm

Hello,
anauta2017 wrote:After upgrade to RAD 10.2.2 TeeChartVCLFMX-2017.22 binaries refused to work, I had to recompile library from source code.
Moreover, recompiled TeeChart3D can not be used with delphi, but works for C++Builder.
We are working on a new installer and we hope to publish it in the next few days.
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

philipljackson
Newbie
Newbie
Posts: 1
Joined: Mon Nov 13, 2017 12:00 am

Re: TeeChart.2017.22 is not compatible with the RAD 10.2.2

Post by philipljackson » Sat Dec 16, 2017 6:14 am

When I run the TeeChart Source Code Recompile Tool for RX10.2 Tokyo, I get the following error

Cannot recompile Delphi package: TeeImport925.dpk
Embarcadero Delphi for Win32 compiler version 32.0
Copyright (c) 1983,2017 Embarcadero Technologies, Inc.
VCLTee.TeeImport.pas(416) Fatal: E2225 Never-build package 'IndySystem' must be recompiled
EXCEPTION:
Compilation aborted.
--------------------------------------------

Please advise

Many Thanks

PLJ

johnnix
Newbie
Newbie
Posts: 11
Joined: Wed Jun 14, 2017 12:00 am

Re: TeeChart.2017.22 is not compatible with the RAD 10.2.2

Post by johnnix » Sat Dec 16, 2017 8:20 am

Hello,

I just updated from Delphi 10.2.1 to 10.2.2 and had to recompile TeeChart but when I try to compile anything with a TChart component the compiler complains that cannot find TeCanvas

Code: Select all

[dcc32 Fatal Error] VCLTee.TeeProcs.pas(98): F2613 Unit 'TeCanvas' not found.
Since i did not change anything in the Lib path I am guessing there is a general issue with TeeChart and 10.2.2?

Regards

Yeray
Site Admin
Site Admin
Posts: 8730
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: TeeChart.2017.22 is not compatible with the RAD 10.2.2

Post by Yeray » Mon Dec 18, 2017 9:50 am

Hello,
philipljackson wrote:When I run the TeeChart Source Code Recompile Tool for RX10.2 Tokyo, I get the following error

Cannot recompile Delphi package: TeeImport925.dpk
Embarcadero Delphi for Win32 compiler version 32.0
Copyright (c) 1983,2017 Embarcadero Technologies, Inc.
VCLTee.TeeImport.pas(416) Fatal: E2225 Never-build package 'IndySystem' must be recompiled
EXCEPTION:
Compilation aborted.
--------------------------------------------
I've installed the Update 2 and the Update 2 with 2004 Hotfix and TeeRecompile in TeeChart Pro v2017.22 finished the job without errors for me here.
Are you using default options in TeeRecompile? Are you using TeeChart v2017.22?
johnnix wrote:I just updated from Delphi 10.2.1 to 10.2.2 and had to recompile TeeChart but when I try to compile anything with a TChart component the compiler complains that cannot find TeCanvas

Code: Select all

[dcc32 Fatal Error] VCLTee.TeeProcs.pas(98): F2613 Unit 'TeCanvas' not found.
Since i did not change anything in the Lib path I am guessing there is a general issue with TeeChart and 10.2.2?
Check the paths are correct and also check "VCLTee" is in the Unit Scope Names.
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

ijbranch
Newbie
Newbie
Posts: 2
Joined: Mon Aug 07, 2017 12:00 am

Re: TeeChart.2017.22 is not compatible with the RAD 10.2.2

Post by ijbranch » Mon Dec 18, 2017 10:23 am

Umm. I have the same issue when I try to incorporate TeeCharts into any of my Apps.
"[dcc32 Fatal Error] VCLTee.TeeProcs.pas(98): F2613 Unit 'TeCanvas' not found."
Just exactly what do you mean by.. "check "VCLTee" is in the Unit Scope Names."? Where does it go? I am not familiar with the terminology.
In VCLTee.TeeProcs, the uses has..
.......
TeCanvas
{$ENDIF}
;

Regards & TIA,
Ian

Yeray
Site Admin
Site Admin
Posts: 8730
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: TeeChart.2017.22 is not compatible with the RAD 10.2.2

Post by Yeray » Mon Dec 18, 2017 2:43 pm

Hello Ian,

Find the Unit Scope Names at "Tools->Options->Environment Options->Delphi Options->Library->Unit scope names"
http://www.teechart.net/support/viewtop ... 277#p61277
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

Eustachio
Newbie
Newbie
Posts: 4
Joined: Wed Jul 26, 2017 12:00 am

Re: TeeChart.2017.22 is not compatible with the RAD 10.2.2

Post by Eustachio » Mon Dec 18, 2017 3:05 pm

After installing TeeChart.2017.22, by loading dclfmxteepro925.bpl I get error:

The procedure entry point @System@Net@Httpclient@Win@TCertificateStore@$bcdtr$qqrv
could not be located in the dynamic library rtl250.bpl

Can I fix this or must wait for new istallation version ?

ijbranch
Newbie
Newbie
Posts: 2
Joined: Mon Aug 07, 2017 12:00 am

Re: TeeChart.2017.22 is not compatible with the RAD 10.2.2

Post by ijbranch » Mon Dec 18, 2017 6:50 pm

Yeray wrote:Hello Ian,

Find the Unit Scope Names at "Tools->Options->Environment Options->Delphi Options->Library->Unit scope names"
http://www.teechart.net/support/viewtop ... 277#p61277
Ahh, OK. Checked and VCLTee is in there, and for my other relevant projects as well.
They all compiled fine without any change under D10.2.1. It is only since D10.2.2, including the 17th Dec release, that this problem has surfaced.

Fixed - Found another article that said to move the TeeChart Delphi Library and Debug paths to the top of the path lists. Did that and all good now. - HTH.

Regards,
Ian
Last edited by ijbranch on Tue Dec 19, 2017 6:16 am, edited 1 time in total.

Eustachio
Newbie
Newbie
Posts: 4
Joined: Wed Jul 26, 2017 12:00 am

Re: TeeChart.2017.22 is not compatible with the RAD 10.2.2

Post by Eustachio » Mon Dec 18, 2017 7:10 pm

Tried with the today published buil 2008 of Delphi 10.2.2
I get the same error.
entry point @System@Net@Httpclient@Win@TCertificateStore@$bcdtr$qqrv
could not be located in the dynamic library rtl250.bpl

Peter

Yeray
Site Admin
Site Admin
Posts: 8730
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: TeeChart.2017.22 is not compatible with the RAD 10.2.2

Post by Yeray » Tue Dec 19, 2017 8:54 am

Hello,

As mentioned above, we are working to publish a new binary version asap. In the meanwhile, only the source code version supports RAD Studio Tokyo Release 2, aka 10.2.2.
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

MTzovaras
Newbie
Newbie
Posts: 1
Joined: Mon Oct 16, 2017 12:00 am

Re: TeeChart.2017.22 is not compatible with the RAD 10.2.2

Post by MTzovaras » Thu Dec 21, 2017 12:27 pm

I installed the latest version 10.2.2 from Embarcdaero (Embarcadero® RAD Studio 10.2 Version 25.0.29039.2004)
I get the error.
entry point @System@Net@Httpclient@Win@TCertificateStore@$bcdtr$qqrv
could not be located in the dynamic library DclTeePro925.bpl

bdw
Advanced
Posts: 124
Joined: Mon Mar 07, 2005 5:00 am
Location: New Zealand
Contact:

Re: TeeChart.2017.22 is not compatible with the RAD 10.2.2

Post by bdw » Fri Dec 22, 2017 8:48 am

Yes I can confirm 10.2.2 version 2004 does not work with binary tchart but source code does work.

Bruce
Newbie
Newbie
Posts: 3
Joined: Tue Oct 17, 2017 12:00 am

Re: TeeChart.2017.22 is not compatible with the RAD 10.2.2

Post by Bruce » Fri Dec 22, 2017 3:31 pm

How much longer is this going to take?

mmpt
Newbie
Newbie
Posts: 1
Joined: Fri May 12, 2017 12:00 am

Re: TeeChart.2017.22 is not compatible with the RAD 10.2.2

Post by mmpt » Wed Dec 27, 2017 3:06 pm

Any news when your paying customers will be able to setup Teechart again? Or do you think it's best not to upgrade Rad Studio, just because of your setup problem?

Post Reply