Chinese char with messy code

TeeChart for ActiveX, COM and ASP
Post Reply
hansan
Newbie
Newbie
Posts: 3
Joined: Tue Oct 14, 2014 12:00 am

Chinese char with messy code

Post by hansan » Mon Feb 02, 2015 9:39 am

I have a problem as follow picture,the server OS is windows2008 simple Chinese and teechart version is 2012axtivex
CLAMPING_FINGERMAX_DISCRETE_TEMP.jpg
CLAMPING_FINGERMAX_DISCRETE_TEMP.jpg (74.27 KiB) Viewed 3394 times

Yeray
Site Admin
Site Admin
Posts: 8876
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: Chinese char with messy code

Post by Yeray » Mon Feb 02, 2015 3:30 pm

Hello,

There are several ActiveX v2012, which one are you observing this problem with?
Have you tried it with the latest version, v2014.0.0.2?

If you still find problems with it, could you please arrange a simple example project we can run as-is to reproduce the problem here?

Thanks in advance.
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

hansan
Newbie
Newbie
Posts: 3
Joined: Tue Oct 14, 2014 12:00 am

Re: Chinese char with messy code

Post by hansan » Wed Feb 04, 2015 2:46 am

I observing this problem with TeeChart2012_0_0_9ActiveX3264.I run the program in Visual Studio it show the Chinese chars,but when I deployed it on IIS the messy codes apeared.

Yeray
Site Admin
Site Admin
Posts: 8876
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: Chinese char with messy code

Post by Yeray » Wed Feb 04, 2015 8:06 am

Hello,

Thanks for the detail, it may help us to discard some possibilities.
However, it would also be interesting to know if the latest version solves the problem for you, and it would help us if we could get a simple example project we can run as-is to reproduce the problem here.

Thanks in advance.
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

hansan
Newbie
Newbie
Posts: 3
Joined: Tue Oct 14, 2014 12:00 am

Re: Chinese char with messy code

Post by hansan » Wed Feb 04, 2015 9:42 am

Hey,I have solved the problem.In the codes I confirmed the font name for the Chinese chars,and the messy code disappeared.

Yeray
Site Admin
Site Admin
Posts: 8876
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: Chinese char with messy code

Post by Yeray » Wed Feb 04, 2015 10:04 am

Hi,
hansan wrote:Hey,I have solved the problem.In the codes I confirmed the font name for the Chinese chars,and the messy code disappeared.
Great news! :)
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

Post Reply