TeeChart Pro v2019 (64bit)

TeeChart for ActiveX, COM and ASP
Post Reply
Shia (Excalibur)
Newbie
Newbie
Posts: 4
Joined: Mon Dec 30, 2019 12:00 am

TeeChart Pro v2019 (64bit)

Post by Shia (Excalibur) » Sun Jan 12, 2020 3:34 pm

Hi,
I am having a number of issues using TeeChart Pro v2019.0.4.25 and TeeChart201964.ocx

Here's the first one:-

I have a real time application monitoring avionics messages which has been converted from 32bit to 64bit (VS 2008 C++) Teechart5 to TeeChart Pro v2019.0.4.25

I am using the same code as used with the 32bit version

When calling

Code: Select all

m_tchart.ChangeSeriesType(series->m_iSeries, scBar);
or scPoint or scFastLine or scArea

I get the following pop up
errorTeeChart.png
errorTeeChart.png (53.33 KiB) Viewed 3154 times
After pressing OK the graphs appear and run.

If I change the type of graph at runtime I get the same result

sometimes i get an error message before calling m_tchart.ChangeSeriesType
Augument out of range


on this line

Code: Select all

m_tchart.GetTools().GetItems(TOOLS_ALARM_YBAND2).SetActive(0);
However, I already passed this line before calling m_tchart.ChangeSeriesType without any problem?

Please advise,

Thanks,

Shia.

Yeray
Site Admin
Site Admin
Posts: 8876
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: TeeChart Pro v2019 (64bit)

Post by Yeray » Thu Jan 23, 2020 8:12 am

Hello Shia,

Sorry for the delayed reply here.
Could you please arrange a simple example project we can run as-is to reproduce the problem here?
Thanks in advance.
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

Shia (Excalibur)
Newbie
Newbie
Posts: 4
Joined: Mon Dec 30, 2019 12:00 am

Re: TeeChart Pro v2019 (64bit)

Post by Shia (Excalibur) » Thu Jan 23, 2020 10:21 am

Thanks but I solved it.

The problems were caused when I copied for the old teechart control to the new (see attached file).

When I created the same tools in the new v2019 64bit version I changed the order,not realizing the order was important. 8)

There were hard coded index's referencing the tools (originally written in 2002!) :|

Therefore, I was addressing the wrong tool, hence the errors.

I just rearranged the tools as per the original version, and everything is working. :D :) :wink:


Shia
Attachments
Tools.png
Tools.png (21.13 KiB) Viewed 3015 times

Pep
Site Admin
Site Admin
Posts: 3198
Joined: Fri Nov 14, 2003 5:00 am
Contact:

Re: TeeChart Pro v2019 (64bit)

Post by Pep » Thu Jan 30, 2020 5:07 pm

Hi Shia,

I'm glad to hear all is working fine for you.

Thanks

Post Reply