Search found 13 matches

by PoLabs
Wed Jul 20, 2016 9:53 pm
Forum: VCL
Topic: Measure axis size (inlc. title, labels, etc..)
Replies: 3
Views: 1293

Re: Measure axis size (inlc. title, labels, etc..)

Hi, thanks for the link. Very helpful. I have very similar solution. Actually the only difference is that mine is not recursive but iterative. I use Title for each axis and I have custom labels so this affects everything... However I managed to find good solution which works fine. I manually calcula...
by PoLabs
Wed Jul 20, 2016 12:45 pm
Forum: VCL
Topic: Measure axis size (inlc. title, labels, etc..)
Replies: 3
Views: 1293

Measure axis size (inlc. title, labels, etc..)

Hi, I am creating vertical axes in runtime and I would like to know how can I measure how much place one axis will take (including labels, title etc..)? Now I use constant 70px (experimentaly defined) for each axis... and then setup Chart.MarginLeft = N * 70 where N is number of axes I create. Howev...
by PoLabs
Wed Jul 20, 2016 10:26 am
Forum: VCL
Topic: Labels on axes automatically hidden when scrolling
Replies: 2
Views: 1072

Re: Labels on axes automatically hidden when scrolling

This is it. Adding jus 1px to each side helped to solve my issue. I don't know how I wasn't aware of those two properties. :)

Thanks!
by PoLabs
Tue Jul 19, 2016 11:00 am
Forum: VCL
Topic: Labels on axes automatically hidden when scrolling
Replies: 2
Views: 1072

Labels on axes automatically hidden when scrolling

Hi, I manually create vertical axes (custom axes) and perfrom axis scroll from code. I noticed that labels on axes become invisible when they approach to IEndPos or IStartPos of axis... How is this controlled? I attached image wanted.png to show you what I mean. On the upper part of picture you can ...
by PoLabs
Mon Jul 18, 2016 11:51 am
Forum: VCL
Topic: TCursorTool is not working on series with custom axes
Replies: 1
Views: 767

TCursorTool is not working on series with custom axes

Hi, I have a problem using TCursorTool. I have a series with custom bottom and left axes. CursorSeries.CustomHorizAxis := MyBottomAxis; CursorSeries.CustomVertAxis := MyLeftAxis; and cursor tool is not working. I have sources of TeeChart and inspected why this is happening and I saw code: Function T...
by PoLabs
Tue Feb 16, 2016 11:24 am
Forum: VCL
Topic: Multi left axes
Replies: 3
Views: 1303

Re: Multi left axes

I managed to get expected result. At first I was doing it wrong because I didn't use TColorBand but I was manipulating grid properties. Now I see how easy is that with adding series to properly positioned axes and using tcolorband on each axis. I am getting access violation (see attachment) but neve...
by PoLabs
Mon Oct 05, 2015 7:52 am
Forum: VCL
Topic: Installing TeeChart PRO VCL Source issues
Replies: 11
Views: 5814

Re: Installing TeeChart PRO VCL Source issues

Thanks for the explanation. I will try to find some time to do that and I will report the results. I also read your new post about how to setup paths in IDE just to make sure I am not missing anything.

Thank you!
by PoLabs
Mon Oct 05, 2015 7:48 am
Forum: VCL
Topic: HowTo setup Paths in the IDE
Replies: 14
Views: 8206

Re: HowTo setup Paths in the IDE

Great stuff! Thanks for that!
by PoLabs
Mon Sep 28, 2015 8:39 am
Forum: VCL
Topic: Installing TeeChart PRO VCL Source issues
Replies: 11
Views: 5814

Re: Installing TeeChart PRO VCL Source issues

I attached image of error I am getting when I run DX10.
by PoLabs
Mon Sep 28, 2015 8:31 am
Forum: VCL
Topic: Installing TeeChart PRO VCL Source issues
Replies: 11
Views: 5814

Re: Installing TeeChart PRO VCL Source issues

Just one note about how I manually "force" it to work. I actually copy all 32bit bpls to SysWow64 and all 64bit bpls to System32. I have to do that manually everytime.
by PoLabs
Mon Sep 28, 2015 8:04 am
Forum: VCL
Topic: Installing TeeChart PRO VCL Source issues
Replies: 11
Views: 5814

Installing TeeChart PRO VCL Source issues

Hi, Since version Pro2014 with source I am having troubles installing packages into IDE using TeeRecompile.exe. It never works for me from the first time. I always have to copy some files and do sime improvisation to make it work somehow. Today I tried to install Steema TeeChart Pro VCL Source Code ...
by PoLabs
Tue Sep 15, 2015 10:26 am
Forum: VCL
Topic: Unit scoping
Replies: 3
Views: 1136

Re: Unit scoping

My current project doesn't include path to precompiled units of TeeChart in Search path because I am setting it up in Library. So I have to add VCLTee to Unit Scope in Library settings. Which makes sense now. That way I never recompile TeeChart sources because they are already. I made a small demo w...
by PoLabs
Mon Sep 14, 2015 3:53 pm
Forum: VCL
Topic: Unit scoping
Replies: 3
Views: 1136

Unit scoping

Hi, I hope this is the right place to ask. I am using Delphi XE8 and I have VCL application. When I added VCLTee prefix to Unit Scope Names in Project options, compiler still reported missing units if I use it: uses TeEngine -> 'TeEngine.pas' cannot be found! Then I added VCLTee prefix in Tools->Env...